Switching website hosts
Incident Report for Munchyroll
Resolved
Successfully switched to our new host provider!
Posted Jun 02, 2021 - 12:58 CDT
Identified
We are switching to a new hosting provider. This means that the site will be offline for a little bit.
Posted Jun 02, 2021 - 12:47 CDT
This incident affected: Website and Stream.